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InvocaKnowledge
Community Manager
Community Manager

Symptoms

A Salesforce Admin might encounter a Salesforce bug when installing the package (version 5.5.4 or lower) related to hitting the custom relationship limit of objects. It might have a message like the following:
Custom Relationship Limit Exceeded
Cannot create new relationship. Each object can have no more than 45 custom relationships, including Master-Detail and Lookup relationships.

 

Applies To

Salesforce Sales Cloud version 5.5.4 or lower

Resolution

  1. Run a Entity Definition Report which will allow you to see how many Lookups and Master-Detail relationships you have in your system.
  2. Use the report to determine which object(s) are at their limit for Custom Relationship Fields.
  3. Remove a field from that object to make space for those added by the Invoca Managed Package.

Cause

The Invoca Managed Package has a Lookup field on each object to point to the related Invoca Call Log record.
  • Account > Invoca Call Log
  • Case > Invoca Call Log
  • Contact > Invoca Call Log
  • Lead > Invoca Call Log
  • Opportunity > Invoca Call Log
If any of those objects is already at their limit for Custom Relationship Fields, then you will likely see this error and preventing the installation of the package.
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