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3713members
1199posts
InvocaKnowledge
Community Manager
Community Manager

Symptoms

When applying Revenue along with a Signal using the Signal API, the request updates the Signal and gets a 200 response code, but the Revenue value is not applied.

Applies To

Signal API requests including the `revenue` parameter.
Example request:
{
"search": {
"transaction_id": "ABCDEFG-123456"
},
"signals": [
{
"name": "purchase",
"revenue": "200.0",
"value": "true"
}
]
}

Resolution

Ensure the name of the signal included in the API request is cased properly (exactly matches the Signal's name in the UI). In our example, the Signal name is "Purchase" rather than "purchase". Correcting the API call to use the correctly cased name of the Signal should resolve.
Example API Request:
{
"search": {
"transaction_id": "ABCDEFG-123456"
},
"signals": [
{
"name": "Purchase",
"revenue": "200.0",
"value": "true"
}
]
}

Cause

When applying Revenue with a Signal the Signal API is very strict with case sensitivity.

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