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1413posts
InvocaKnowledge
Community Manager
Community Manager

Symptoms

response": {

  "statusCode": 403,

  "status": "Forbidden",

  •   "body": "{\"errors\":{\"class\":\"InvalidInput\",\"invalid_data\":\"Call must be present\"}}",

Applies To

  • Signal API

Resolution

You could either delay their requests a bit to account for the call finishing importing or pass the call_in_progress parameter as true if you don't need the response we currently provide them

Cause

The request provides a transaction ID that has yet to exist in the Invoca platform. This caused a race between the request being made and the call finishing importing into Invoca. It would be good to check with them to see if they have timing on when the call finished vs. when the API request was made.

Additional Information

Signal API documenation


The downside is you won't get an immediate response to indicate the update was successful. 


201 Created

Request was accepted with the call_in_progress parameter set to true

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