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InvocaKnowledge
Community Manager
Community Manager

Symptoms

  • The number doesn't swap on the mobile page
  • The number does swap on the desktop page
  • If your webpage utilizes "data binding"
  • Running Invoca.PNAPI.run() within the console forces the number to swap
  • If you continue to scroll down the page the number swaps back to the old one

Applies To

  • Invoca Tag

Resolution

In this case, you have something called “data binding.” In order for the Invoca number to persist, you'll need to eliminate data binding within your SPA (Single Page Application) on the phone number field.


In the end, the customer’s developers need to have an alternative method to insert their phone number on the page so it won’t override Invoca's number when it is replaced

Cause

Data binding: A general technique that binds together two data sources (or two separate representations of the same data) and synchronizes them.


Whenever the user scrolls, the application syncs the data from the back end with the UI element on the front end, thus overriding Invoca's update of the data on the UI element. This only happens on page load or when Invoca.PNAPI.run() is called.


It is a good practice in modern software development, but with Invoca, it is never good because the customer’s application overrides Invoca's attempt to replace the phone number. The customer’s phone number is “bound” to their backend data when in place.

Additional Information

Data Binding article from Medium for reference

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