Symptoms
Agent Voice ID is showing many blank or incorrect names associated with calls.
Applies To
Agent Voice ID
IFCC
Resolution
- Check in the Agent Voice ID portal “dashboard” tab that 90-100% of agents are successfully enrolled as required. Enrolled means that the user has successfully completed the enrollment process.
- Validsoft Portal Link: https://invoca.validsoft.cloud/admins
- Login
- Click on the Dashboard on the left-hand side. The first chart will show the percentage of enrolled
- If less than 90%, have the remaining agents complete the enrollment process (100% is preferred)
- Proceed to Step 2
- Confirm there are no other non-enrolled agents to be scored that should get enrolled.
- If Yes, get to 90%+ enrollment
- If NO, proceed to step 3
- Confirm there are no NON-agents answering calls
- If Yes, review the Signal that triggers calls to be sent to Validsoft. Work with CSM/Customer to update the Signal to avoid sending these calls.
- To view Signals set, go to Go into Invoca Network
- Click on integrations
- Click into Agent Voice ID Integration
- Click Edit on the 3 dots to the right of the Action to view the Triggered By signals
- Navigate to Signals on the left-hand side of the Invoca UI to find the signal identified above
- Review the rule for firing the Signal to help identify if there is a way to update this to avoid sending calls answered by Non-agents
- Verify if problem calls are being transferred from one agent to another. By default, we name the first agent on the call.
- If no, proceed to Step 5
- If yes, you can request with Support to change the configuration to name the last transferred agent answering customer calls. This change impacts ALL tenant calls.
- To change this, submit an Invoca Support Case
- Have calls been audited before?
- If not, conduct a 100-call audit
- Once complete, Share results with Invoca Support to “calibrate” the Voice ID.
Cause
- Less than 90% of agents are successfully enrolled as required.
- There are other Non-enrolled agents answering calls
- Calls are being transferred