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InvocaKnowledge
Community Manager
Community Manager

Symptoms


  • Leads weren't being created for every call


Applies To

  • Salesforce

Resolution

A recent Salesforce patch (5.5.3) changed the code and now exposes the field mapping option for leads when no objects are selected for matching but the "Enable Lead Creation" checkbox is enabled.

Cause

Previous packages provided an option to do no matching against existing records and to have the package create a new Lead for every call. This option wasn't initially included in version 5.5.

Additional Information

You should be mindful of two things when making changes to your field mapping configuration. Firstly, unselecting the Lead object for matching will clear out the field mapping you have configured. This means you will need to reconfigure each field.


Secondly, you must be very careful when setting the field mapping for required fields. For example, if you map an Invoca Call Log field to the Last Name field on the Lead, you need to ensure the Invoca Call Log field you select for matching will always have a value. If the Invoca field is blank, it will cause an error if you map it to a required field.


These are important considerations as you make changes to your mapping section. While it may not be a problem based on your current setup, it's something to note if you add more fields in the future.


We recommend installing the patch in your Sandbox first and completing a through round of QA before installing in production

Need more help?

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