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4321members
1416posts
InvocaKnowledge
Community Manager
Community Manager

Symptoms

  • Requests to Google Campaign Manager are not receiving 200 Success responses and therefore call conversions is not successfully appearing in GCM
  • In the integration logs, the following error can be found within the response body within the delivery history

{

 "error": {

  "code": 403,

  "message": "The caller does not have permission",

  "errors": [

   {

    "message": "The caller does not have permission",

    "domain": "global",

    "reason": "forbidden"

   }

  ],

  "status": "PERMISSION_DENIED"

 }

}

Applies To

  • Google Campaign Manager integration

Resolution

Make sure the following:

  1. The Authenticating User of the Invoca integration is an Admin and has Insert/update offline conversion permissions in Google Campaign Manager
  2. If using the standard GCM tile integration, ensure that the GCM Profile ID tied to the Action matches the GCM Profile ID of the authenticating user
  3. If using a webhook integration, ensure that the GCM Profile ID in the webhook matches the GCM Profile ID of the Authenticating user
  4. Make sure the authenticating user has access to the floodlights within GCM

 

Cause

The root cause of this issue is typically that the authenticating user of the integration has changed but not all of the steps have been completed to transfer over the integration to the new user. 

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