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InvocaKnowledge
Community Manager
Community Manager

Symptoms

Google Adword keyword data isn't populating

Applies To

  • Google Ads
  • Network level integration

Resolution

  1. Confirm the Google Ads account is configured according to the documentation
  2. Confirm marketing data field Google Customer ID is implemented
  3. Ensure the Invoca tag is updated with the "customer_id" marketing data field 
  4. The Google customer_id would need to be added to the Final URL suffix within Google Ads
  5. Refer to Google documentation for specifics on URL setup 
    1. If all ads in a client account use the same tracking URL parameters, add the parameters to the account's Final URL suffix. Otherwise, add the parameters to a Final URL suffix at the campaign level or a lower. The suffixes at lower levels override suffixes from higher up. 

Cause

If any of the following steps are missed or not implemented correctly, keyword data will not appear in Invoca reports.

Additional Information

Invoca for Google Ads: Sending Google Ads data back to Invoca

 

Two data points must be returned to Google to generate keyword data in reports.

  1. Google Click ID
  2. Google Customer ID

Invoca receives keyword data from Google, but there are instances where the gclid may be invalid or Google cannot decode it. However, this is expected to happen on average in less than 10% of the total data.

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