cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
3743members
1220posts
InvocaKnowledge
Community Manager
Community Manager

Symptoms

  • You are seeing attribution the g_cid coming in as "not_found."
  • If you have a single Invoca Tag deployed on multiple domains, you may be seeing attribution for the g_cid on some domains being captured correctly, and "not_found" on others.

Applies To

  • Customers who are capturing the g_cid attribution in their reporting.
  • Customers integrated with Google Analytics and have the options.integrations.googleAnalytics = true; code in their custom code block.
  • Customers relying on Google Tag manager to handle their tagging for Invoca and Google Analytics. 

Resolution

To resolve this issue, you will need to update how the Invoca tag reads this value. 
  1. Navigate to the Invoca Tag and create a new draft
  2. Next to the g_cid Marketing Data Field update the Date Source Type to 'JavaScript Data Layer' and the Data Source Name to 'gaGlobal.vid'.Screenshot 2024-01-03 at 12.15.21 PM.png
  3. To implement the changes, click on 'Save & Go Live'.

Cause

The customer had both Google Analytics 4 and Google Universal Analytics deployed through Google Tag Manager on some domains, and only Google Analytics 4 on others. Because of this, The Invoca Tag was expecting the g_cid to be coming from info picked up by the Google Universal Analytics Property IDs, which were not present on domains which only had Google Analytics 4. This is why attribution for the g_cid on those domains came back as "not_found."
Need more help?

Don't see what you are looking for? You can ask the Community or contact support.