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InvocaKnowledge
Community Manager
Community Manager

Symptoms

  • The Adobe Analytics Pre-Transfer Webhook is not firing on calls that it is expected to fire on.
  • Calls that the webhook is not firing on are from Syndicated Campaigns that forward calls to another Invoca Network.

Applies To

  • Customers who have one or more active Syndicated Campaigns.
  • Customers who have an Adobe Analytics integration that uses a Pre-Transfer Webhook.
  • Customers who would like to see call data from their Syndicated Campaign(s) passing to Adobe Analytics.

Resolution

Solution 1: One Post-Call Webhook for all Syndicated Campaigns

  1. Create a new Short Text Marketing Data Field for the Adobe Report Suite ID.
  2. Create a new Post-Call Webhook at the Network Level. Title it something similar to your Pre-Transfer Webhook but differentiate it as a Post-Call Webhook.
  3. Copy over the endpoint URL and body from the Pre-Transfer Webhook.
  4. In the Body of the Post-Call Webhook, replace the hardcoded <reportSuiteID> value with a Substitution Parameter for the Report Suite ID Marketing Data Field you created.
  5. Under the Firing Conditions tab, set the webhook to fire on "All calls." Save the webhook.
  6. Create a new Lookup Table in the "Tables" section of your Data Diction and choose the Profile Campaign ID or Profile Campaign Name as the lookup field.
  7. Remove all columns except for the Adobe Report Suite ID column. Create rows for each of your syndicated campaigns and upload the lookup table.

Now, the Report Suite ID in your Post-Call Webhook will only be defined for calls coming from the specified Syndicated Campaigns. The webhook will fire on every call, but only the deliveries that include a Report Suite ID will be ingested by Adobe, effectively filtering out all non-syndicated calls from this webhook request to the Adobe Data Insertion API.

 

Solution 2: One Post-Call Webhook for each Syndicated Campaign

  1. Navigate to the Profile level of the Profile that houses your Syndicated Campaigns.
  2. Create a Post-Call Webhook and include one of your Syndicated Campaigns in the title.
  3. Copy over the endpoint URL and body from your Pre-Transfer Webhook. Do not make any changes to the body.
  4. Under the Firing Conditions tab, select the Campaign that you included in the webhook title.
  5. Set the webhook to fire on "All calls" and save the webhook.
  6. Repeat steps 2-5 for each of your syndicated campaigns, and do so within any other necessary profiles.

Cause

Pre-Transfer Webhooks are triggered when a call connects outside of Invoca. Syndicated calls are forwarded to another Invoca network and then connected outside of Invoca by that network. Because of this, Pre-Transfer Webhooks are not triggered in the Invoca network that the call originated from, only the network where the call connected outside Invoca. Post-Call Webhooks do not have this same limitation, and will fire after every call regardless of its syndication status.

 

 

Additional Information

Post-Call Webhooks have a lower chance of being associated with the Adobe session, especially if they are processed 30 minutes or more after the call starts. This is why the standard integration practice is to use a Pre-Transfer Webhook to make requests to the Data Insertion API.

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