Symptoms
- User sees a 403 error when attempting to log into the Invoca platform via SAML/SSO.
- The error message included with the SAML response read, "Contact phone number can't be blank, Contact phone number Invalid" (SSO debugger needed to read error message).
- Likely the first time the user has attempted to login via SAML/SSO.
Applies To
- SAML/SSO integration
- Customers who are implementing the Invoca SAML/SSO integration
Resolution
- Within your Identity Provider, access the user attributes in your user configuration.
- Ensure that your user attributes include the following:
- first_name
- last_name
- contact_phone_number
- If the option attribute organization_type is being used, and the value is either "Advertiser" or "Affiliate", then organization_id_from_network is required.
- If any of these attributes are missing, add them to the identity provider user configuration.
Cause
The customer did not have the required user attribute, contact_phone_number, included in their user configuration.
Additional Information
The contact_phone_number attribute does not have to be unique to each user, it just needs to be a valid phone number. A generic number can be set for all users.