cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
4321members
1416posts
InvocaKnowledge
Community Manager
Community Manager

Symptoms

  • User sees a 403 error when attempting to log into the Invoca platform via SAML/SSO.
  • The error message included with the SAML response read, "Contact phone number can't be blank, Contact phone number Invalid" (SSO debugger needed to read error message).

  • Likely the first time the user has attempted to login via SAML/SSO.

Applies To

  • SAML/SSO integration
  • Customers who are implementing the Invoca SAML/SSO integration

Resolution

  1. Within your Identity Provider, access the user attributes in your user configuration.
  2. Ensure that your user attributes include the following:
    1. first_name
    2. last_name
    3. contact_phone_number
    4. If the option attribute organization_type is being used, and the value is either "Advertiser" or "Affiliate", then organization_id_from_network is required.
  3. If any of these attributes are missing, add them to the identity provider user configuration.

Cause

The customer did not have the required user attribute, contact_phone_number, included in their user configuration.

Additional Information

The contact_phone_number attribute does not have to be unique to each user, it just needs to be a valid phone number. A generic number can be set for all users.

Need more help?

Don't see what you are looking for? You can ask the Community or contact support.